Sommaire

  • Présentation
  • Matériel et logiciel requis
  • Le fichier de configuration
  • Démarrage du logiciel
  • La fenêtre principale
  • La fenêtre "Gestion"
  • La barre de "Navigation"
  • La fenêtre "Prise de notes"
  • Note importante pour la navigation
  • Exploitation des traces
  • Comment éliminer des pages de la trace
  • Installation
  • Désinstallation du logiciel
  • Auteurs - Contacts


Présentation

[ Accueil ]

ARI trace et analyse toutes les requêtes partant du navigateur. Il mémorise toutes les pages visitées. Il reconnaît les requêtes adressées aux moteurs de recherche et aux annuaires. Pendant la navigation, ARI est transparent pour l'utilisateur.

ARI construit un historique de la recherche organisé par sessions, recherches, sites et pages.
Cet historique permet soit de consulter hors connexion les recherches effectuées et les documents visités, soit de repartir d'une recherche ou d'une page en cours de navigation.

A partir de l'historique et des pages mémorisées, l'utilisateur peut créer un document personnel par extraction, composition et édition de fragments des documents visités et modifier la mise en page du document.
Chaque document personnel peut être sauvegardé, imprimé et ensuite édité avec un éditeur HTML.

Le module de gestion permet d'inscrire des utilisateurs, de consulter leur travail, d'archiver leurs dossiers, de configurer le logiciel et d'en adapter certains aspects comme la mise en page de notes.
Le paramétrage du logiciel permet de fixer l'adresse de départ de la navigation, le répertoire de sauvegarde des données des utilisateurs, le modèle HTML utilisé lors des prises de notes et de contrôler l'accès au logiciel par un mot de passe.

Les traces et les historiques sont des documents exploitables avec Excel.

ARI a pour but de faciliter une pratique raisonnée de la recherche d'informations sur la toile. Il peut être employé pour initier des élèves ou des étudiants, pour observer leur comportement de recherche. Il peut aussi être utile à tout internaute pratiquant régulièrement la recherche d'informations.

ARI, un logiciel qui vous veut du bien !


Fichier de configuration

[ Accueil ][ Remonter ]

Les principaux paramètres de configuration du logiciel (fixés par défaut dans le fichier texte ari.ini) peuvent être modifiés avec ARI (voir la fenêtre "Gestion des utilisateurs"). Le fichier ari.ini peut aussi être édité avec le Bloc-Notes ou Wordpad. Dans ce cas, ce fichier doit TOUJOURS ETRE ENREGISTRE AU FORMAT TEXTE, dans le dossier de l'application, sous le même nom : ari.ini.

Il est conseillé de fixer au moins le répertoire de sauvegarde des données des utilisateurs.

L'indication des différents paramètres de configuration est précisée dans ari.ini de la façon suivante :
- une étiquette entre [] précise le paramètre : [ACCES_GESTION], [SAVE_PATH_USERS], etc..
- le (ou les) code(s) associé(s) correspondants au paramètre sont précisées à la suite : CODE, URL, MODE, etc..
- ces codes sont suivis de l'option
Les étiquettes et les codes doivent commencer en début de ligne.
En l'absence d'une option, c'est l'option par défaut qui est prise. Pour annuler les options, il suffit de les faire précéder d'une apostrophe (').

Si le fichier ari.ini est absent, il est recréé avec des options par défaut.
Dans la description ci-dessous figurent les deux types d'options par défaut :
- (1) option par défaut en l'absence du fichier ari.ini
- (2) option par défaut proposée dans le fichier ari.ini livré avec le logiciel

1- Accès à la gestion des utilisateurs

Etiquette du paramètre [ACCES_GESTION]
Code associé : CODE=

Valeur par défaut (1) et (2) : vide (la gestion est accessible à tous)
Exemple : [ACCES_GESTION]
CODE=123xyz

2- Accès au logiciel

Etiquette du paramètre [PASSWORD]
Code associé : CODE=

Valeur par défaut (1) et (2) : vide (le logiciel est accessible à tous)
Exemple : [ACCES_GESTION]
CODE=xyz123

3- Répertoire de sauvegarde des utilisateurs

Etiquette du paramètre [SAVE_PATH_USERS]
Code associé 1 : MODE=ABSOLUTE ou MODE=RELATIVE
Code associé 2 : REPERTOIRE=

MODE=ABSOLUTE ou MODE=RELATIVE doit être obligatoirement précisé.

- Répertoire par défaut (1) : rep_application\Users (rep_application étant le répertoire d'installation de l'application, par défaut : Program Files/ARI).
- Répertoire par défaut (2) : C:\utilisateurs

Le MODE d'adressage du répertoire peut être précisé (sans espace) en absolu ou relativement au dossier d'installation de l'application. Exemples :

[SAVE_PATH_USERS]
MODE=ABSOLUTE
REPERTOIRE=D:\utils
ou
REPERTOIRE=\\nom_de_serveur\public\utils
(\\ précise un autre ordinateur)

[SAVE_PATH_USERS]
MODE=RELATIVE
REPERTOIRE=\utils
ou
REPERTOIRE=..\utils

Si le répertoire de sauvegarde des utilisateurs n'existe pas, il est créé. A la racine de ce répertoire sera créé le fichier "Users.txt" contenant les noms des utilisateurs inscrits.

A chaque inscription d'un utilisateur, le logiciel crée un sous-répertoire ayant le nom de l'utilisateur, dans lequel seront sauvegardés les traces, l'historique, les pages téléchargées et toutes les données concernant son travail.

ATTENTION : il est impératif de respecter la casse (majuscules/minuscules) des noms de répertoires et de fichiers telle qu'elle apparaît avec l'explorateur Windows. Le non respect de la casse peut rendre invisibles les pages sauvegardées lors de la navigation.

4- URL de départ de navigation (page de démarrage)

Etiquette du paramètre [STARTING_URL]
Code associé : URL=

Valeur par défaut : vide (l'URL de départ sera celle définie dans les options Internet d'Internet Explorer)
Exemple : [STARTING_URL]
URL=http://www.inrp.fr/Tecne/
ou
URL=D:\Vrac\MonFichier.htm

5- Répertoire des pages à éliminer (publicités)

Etiquette du paramètre [PUB_PATH]
Code associé 1 : MODE=ABSOLUTE ou MODE=RELATIVE
Code associé 2 : REPERTOIRE=

Même mode d'adressage que le répertoire de sauvegarde des utilisateurs (voir ci-dessus).

Permet de préciser le dossier où se trouve le fichier pub.txt

6- Type de suivi (traçage)

Etiquette du paramètre [TRACE_MODE]
Code associé : MODE=

Modes possibles :
.......... Mode 1 : MODE=Minimum
.......... Mode 2 : MODE=Intermédiaire
.......... Mode 3 : MODE=Complet

Valeur par défaut (1) et (2) : MODE= Intermédiaire

Précise le type de suivi (les traces). Les trois types pré-définis sont :

- MODE=Minimum : la trace contient :
. les ouvertures et fermetures de session (OSess, FSess),
. les ouvertures de fenêtre (OFen),
. les débuts de navigation (DNav),
. les titres des fenêtres (Titre)
. et les clics souris (Mdown) sur les liens de la fenêtre de navigation en cours.
- MODE=Intermédiaire : la trace contient en plus :
. les fins de navigation (FNav)
- MODE=Complet : la trace contient en plus :
. les débuts et fins de chargement des fenêtres IE (Dcharg, Fcharg),
. les déplacements de la souris (MOver) sur les objets de la fenêtre de navigation en cours

7- Modèle utilisé pour la prise de notes

Etiquette du paramètre [MODELE]
Code associé : NOM=

Valeur par défaut NOM=modele_defaut.txt

Précise le nom du modèle qui est utilisé pour la mise en page lors des prises de notes. Ce nom correspond à un fichier d'extension .txt
qui est sauvegardé dans le répertoire \modeles de l'application ARI : rep_application\modeles

8- Archivage des séances

Etiquette du paramètre [ARCHIVAGE_SEANCE]
Code associé : MODE=OUI ou MODE=NON

Par défaut : MODE=NON

Cette option permet de préciser si à la fin d'une séance ARI, on sauvegarde automatiquement ou non toutes les données de l'utilisateur dans un fichier comprimé d'extension .zip.
Attention : chaque fichier zip peut occuper plusieurs Mo sur le disque dur. Il est aussi possible d'archiver au cas par cas les données d'un utilisateur (voir la fenêtre "Gestion").

Rappel :

Si le fichier est édité avec WordPad ou NotePad, une fois les modifications apportées, sauvegarder le fichier "ari.ini" dans un format texte (TXT) en lui conservant son extension ".ini".
Ce fichier est aussi modifiable dans le module de gestion. Dans la version actuelle, les seuls paramètres qui ne sont pas accessibles par le module de gestion sont : l'accès au logiciel [PASSWORD], l'indication du répertoire des publicités [PUB_PATH], et l'archivage des séances [ARCHIVAGE_SEANCE] (voir la "Gestion des utilisateurs").


Eliminer des pages de la trace

[ Accueil ]

Le fichier "pub.txt" est constitué d'une liste contenant un extrait des URL qui affichent des publicités, ou autres (pages personnelles, etc.), repérées comme inutiles et qui s'ouvrent dans la fenêtre en cours ou dans une nouvelle fenêtre. Ces appels ne seront pas tracés.

Lorsque vous repérez de telles adresses, vous pouvez les ajouter à la liste existante de "pub.txt". Il n'est pas conseillé de copier toute l'URL ce qui limiterait considérablement la portée de l'interdiction, mais seulement la partie qui apparaît systématiquement lors de l'appel des pages à éliminer.

Pour éliminer des URL telles que

http://www.multimania.fr/general/pub/perso.......
http://www.multimania.fr/general/pub/popup/perso.phtml?....

Il suffit d'ajouter dans le fichier "pub.txt" :

www.multimania.fr/general/pub/

Ce fichier peut-être édité par n'importe quel traitement de texte.
Mais il doit être IMPERATIVEMENT sauvegardé au format TEXTE (.txt).


Configuration requise

Matériel et logiciel nécessaire

[ Accueil ]
Matériel et logiciels requis :
. Windows 95/98/Me/XP ou 2000
. Microsoft Internet Explorer 5.0 ou plus
. 64 Mo de mémoire vive
. 5 Mo sur disque pour l'installation
. 2 à 3 Mo par heure de navigation


Installation

[ Accueil ]
        [ Fichier de configuration ]
        [ Sites à éliminer ]
        [ Désinstallation du logiciel ]

Si ARI a déjà été installé vous devez le désinstaller (voir comment Désinstaller le logiciel ).

L'installation se fait en 3 étapes :
1. Recopie des fichiers d'installation
2. Installation de ARI
3. Paramétrage du logiciel
Dans une configuration en réseau, l'installation devra se faire sur chaque poste utilisateur.

1. Recopie des fichiers d'installation

Recopier, dans un répertoire temporaire de votre choix, selon le téléchargement effectué :

  • soit les 5 fichiers nécessaires à l'installation : "setup.exe", "setup.lst", "ari1.cab", "ari2.cab", "ari3.cab"
  • soit le fichier "ariv433.exe". Dans ce cas double-cliquer ensuite sur ce fichier pour extraire, les fichiers nécessaires à l'installation.

2. Installation

2.1 Fermer toutes les applications en cours, autres que l'explorateur.
2.2 Lancer setup.exe
2.3 Suivez les instructions
Selon l'état du système, on peut être amené à redémarrer Windows en cours d'installation pour mettre à jour quelques bibliothèques de fonctions (DLLs). Cette opération est normale.

Le répertoire d'installation par défaut est "\Program Files\ARI".
Dans ce répertoire, on trouve alors les fichiers suivants :
. "ari.exe" (l'application), "ari.ini", "pub.txt", "lisezmoi.txt", "documentation.txt", "extrait.htm", "digest.htm", "fragment.htm", "modele.bmp", "modele.txt", "St6unst.log" et trois dossiers "moteurs", "aide" et "modeles".
. Dans le dossier "moteurs" on trouve 5 fichiers : "moteur_google.txt", "moteur_nomade.txt", "moteur_altavista.txt", "moteur_yahoo.txt" et "moteur_voila.txt".
. Dans le dossier "aide" on trouve le fichier "ari.chm" et dans le dossier "modeles" les fichiers nécessaires à la définition des modèles disponibles pour la prise de notes.

Tous ces fichiers et dossiers sont indispensables à l'exécution du logiciel.
"ari.ini" est le fichier de configuration et de paramétrage du logiciel (voir Fichier de configuration).
"pub.txt" permet d'éliminer les publicités inutiles (pages personnelles, etc.). Il peut être placé dans un nouveau répertoire, à condition de créer ce répertoire et de modifier la configuration "ari.ini" (voir Ajout de publicités à éliminer).

3. Paramétrage du logiciel

Il se fait en modifiant le fichier de configuration "ari.ini" (voir Fichier de configuration). Si ce fichier n'existe il sera créé avec des valeurs par défaut.

Voir aussi comment Désinstaller le logiciel


Désinstallation du logiciel

[ Accueil ]

Si vous désirez désinstaller ARI, suivez ces instructions :

· Cliquer sur le menu de démarrage situé sur la barre de tâches de Windows et sélectionner Paramètres/Panneau de configuration
· Double-cliquer sur Ajout/Suppression de programmes
· Sélectionner ARI à partir de la liste et cliquer Ajouter/Supprimer
· Confirmer votre intention de désinstaller ARI
· Quand la désinstallation est terminée, utiliser l'Explorateur de Windows pour détruire le répertoire d'installation de ARI.


Démarrage

[ Accueil ]

Pour démarrer le programme cliquez sur le bouton "Démarrer" de la barre des tâches, puis pointez sur "Programmes" et, dans le menu qui apparaît, sélectionnez "Ari" et cliquez.

Si un mot de passe a été précisé dans le fichier "ari.ini" (voir [PASSWORD] dans le fichier de configuration), il est demandé au lancement et seuls les utilisateurs qui le connaissent pourront utiliser le logiciel.

Dans toutes les fenêtres, pour appeler l'aide taper F1 ou cliquer sur le bouton d'aide s'il existe.

La fenêtre d'aide reste au premier plan ; la redimensionner pour consulter l'aide et utiliser le logiciel simultanément. Quand on passe d'un module à l'autre, la fenêtre d'aide se ferme. Taper sur F1 pour obtenir l'aide correspondant au module.


Fenêtre principale

[ Accueil ]

C'est la fenêtre qui s'affiche au lancement du logiciel. Elle contient :

  • 5 boutons "Quitter", "Naviguer", "Prendre des notes", "Gérer" et "A propos",
  • 1 liste déroulante "Utilisateur",
  • une boîte dans laquelle est indiqué le mode de travail en cours : "utilisateur" ou "administrateur"
  • et en dessous sont affichés le dossier des utilisateurs et le modèle par défaut pour la mise en page.

- Le bouton "Quitter" permet de quitter le logiciel.

- Le bouton "Naviguer" permet de naviguer normalement avec Internet Explorer tout en conservant un historique détaillé (voir la description de "La barre masquable de Navigation").

- Le bouton "Prendre des notes" permet de revoir les documents visités et de prendre des notes à partir d'extraits de ces documents (voir la description de la fenêtre correspondante).

- Le bouton "Gérer" donne accès à la gestion des utilisateurs (inscription, suivi des inscrits, etc., voir la fenêtre "Gestion").

- Le bouton "A propos" permet d'afficher des informations concernant le logiciel.

-La liste déroulante "Utilisateur" affiche la liste des utilisateurs inscrits. Choisir un nom dans cette liste. Le nom de l'utilisateur, le nombre de sessions effectuées, la liste des sessions de navigation précédentes sont alors affichées ainsi que ses éventuelles appartenances à des groupes. Les boutons "Naviguer", "Prendre des notes" deviennent opérationnels. A partir de cet instant, toutes les données de navigation et les notes sont enregistrées sous le nom de l'utilisateur sélectionné.


Gestion

La fenêtre Gestion

[ Accueil ]
        [ Configuration ] [ Gestion des utilisateurs ]
        [ Mises à jour ]
        [ Modèles ]
        [ Groupes ]

Son accès peut-être réservé (voir [ACCES_GESTION] dans Fichier de configuration).

Elle propose un groupe de 4 onglets :

  • Configuration
  • Utilisateurs
  • Mises à jour
  • Modèles
  • Groupes

et 3 boutons de sortie : "Quitter en mode utilisateur", "Quitter en mode administrateur" et "Annuler", décrits ci-dessous.

Sélection d'utilisateurs dans la liste des inscrits

Les onglets 1,2,3 et 5 affichent la liste des utilisateurs ou groupes d'utilisateurs inscrits. Dans cette liste, les noms sont triés par ordre alphabétique croissant. La liste permet de sélectionner un ou plusieurs inscrits. Pour sélectionner plusieurs inscrits séparemment, maintenez la touche CTRL enfoncée puis cliquez sur les éléments à sélectionner. Pour sélectionner un groupe d'inscrits qui se suivent dans la liste, sélectionner le premier et en maintenant enfoncé le bouton de la souris, amener la souris sur le dernier élément à sélectionner.

Boutons "Quitter en mode utilisateur" ou en "mode administrateur"

En "mode utilisateur", lorsque l'utilisateur "dupont" navigue, ses requêtes sont sauvegardées dans deux fichiers : "dupont.csv", "dupont_Histo.csv". Le premier contient les traces des événements des différentes sessions, le second contient les historiques des différentes sessions.

Les pages vues sont également téléchargées dans le répertoire html du dossier de l'utilisateur. Leur nom est calculé à partir de la date et de l'heure du téléchargement. Les images respectives de chaque page sont elles-mêmes sauvegardées dans des répertoires .img de même nom créé dans le répertoire html.

En "mode administrateur", si on navigue, rien de ce qui précède n'est sauvegardé. Ce mode permet à l'enseignant de revoir le parcours d'un utilisateur sans modifier ses fichiers (pages vues, moteurs de recherche utilisés, équations de recherche, etc.).

Lorsqu'un de ces 2 boutons est activé, il y a sauvegarde éventuelle, dans le fichier de configuration ari.ini, des modifications demandées dans les onglets "Configuration" et "Modèles" puis on revient à la fenêtre principale et le mode est affiché dans cette fenêtre.

Bouton annuler

Il permet de revenir à la fenêtre principale sans que d'éventuelles modifications concernant la configuration du logiciel soient prises en compte.


onglet Configuration

L'onglet Configuration

[ Accueil ] [ Remonter ]

Il affiche la liste des utilisateurs inscrits et propose de modifier dans le fichier de configuration d'ARI, le dossier de sauvegarde (et d'inscription) des utilisateurs, l'URL de départ de navigation, le type de sauvegarde des traces, le code d'accès à la gestion et l'archivage automatique (ou non) en fin de séance du travail des utilisateurs.

Sauvegarder la configuration

Permet d'enregistrer ou non dans le fichier ari.ini les modifications des quatre paramètres ci-dessus. Si la case est cochée, alors les modifications restent valides pour les sessions suivantes ; sinon la configuration n'est pas enregistrée et les modifications sont valides tant qu'on ne quitte pas le logiciel et perdues dès qu'on le quitte.

Archivage automatique en fin de séance

Permet de sauvegarder ou non toutes les données des utilisateurs qui ont lancé une session, c'est-à-dire chaque fois qu'un utilisateur a été sélectionné dans la fenêtre principale, qu'il est ou non navigué ou pris des notes. Il est à noter que la sauvegarde d'un utilisateur nécessite généralement plusieurs méga-octets sur le disque dur (environ plus de 2 Mo par heure de travail) ; aussi cette sauvegarde automatique ne doit être cochée que si l'on dispose de suffisamment de place sur le disque dur.

L'archivage peut aussi être effectué à la demande (voir l'onglet "Utilisateurs").

Dossier de sauvegarde

Il contient toutes les informations relatives aux utilisateurs inscrits (fichier "Users.txt" et dossiers des utilisateurs).
Pour modifier le chemin du dossier de sauvegarde, cliquer sur le bouton à droite "...".
Une fenêtre de dialogue permet de sélectionner un nouveau dossier ou d'en créer un s'il n'existe pas. On peut aussi supprimer un dossier s'il est vide.
"Ok" permet de valider le choix, "Annuler" annule la modification.

Url de départ de navigation

L'Url sur laquelle est lancée la navigation est affichée dans une zone de texte. Pour la modifier, cliquer dans la zone de texte et modifier son contenu. On peut ainsi choisir de démarrer sur un moteur de recherche (exemple : http://www.google.fr/) ou sur une page locale (exemple : C:\MonGuide\accueil.htm) ou ...
Attention à distinguer "/" quand il s'agit d'une Url extérieure et "\" quand il s'agit d'un fichier sur un disque local).

Sauvegarde des traces

Précise le type de sauvegarde : Minimum, Intermédiaire ou Complet. Cliquer sur la liste déroulante et sélectionner le type (voir [TRACE_MODE] dans "Fichier de configuration").

Code d'accès administrateur

Contient le code qui permet d'accéder à la "gestion des utilisateurs".
Si la zone de texte est vide tout le monde a accès à la gestion. Pour changer le code, cliquer dans la zone de texte et modifier son contenu.
Si un code existe, n'oubliez pas de le noter. Toutefois si on ne s'en souvient pas, on peut toujours le lire en consultant le fichier de configuration ari.ini avec WordPad par exemple.

Utilisateurs inscrits

Les noms sont triés par ordre alphabétique croissant.
La liste affiche les utilisateurs et groupes inscrits dans le dossier de sauvegarde sélectionné.


onglet Gestion des utilisateurs

L'onglet Gestion des utilisateurs

[ Accueil ] [ Remonter ]

Utilisateurs inscrits

Les noms sont triés par ordre alphabétique croissant. La liste permet de sélectionner un ou plusieurs inscrits. Pour sélectionner plusieurs inscrits séparemment, maintenez la touche CTRL enfoncée puis cliquez sur les éléments à sélectionner. Pour sélectionner un groupe d'inscrits qui se suivent dans la liste, sélectionner le premier et en maintenant enfoncé le bouton de la souris, amener la souris sur le dernier élément à sélectionner.

Inscrire un utilisateur

Ce bouton de commande ouvre une fenêtre invitant à inscrire un nom d'utilisateur (14 caractères maximum) ne figurant pas encore dans la liste des inscrits. Le nom sera converti en minuscules et les espaces remplacés par "_".

Dès que l'inscription est validée, le nom de l'utilisateur ("dupont" par exemple) est ajouté à la liste des inscrits (fichier "Users.txt") et un répertoire de même nom ("dupont") est créé dans le dossier de sauvegarde. Un fichier de trace ("dupont.csv") et un fichier historique ("dupont_Histo.csv") sont aussi initialisés dans le répertoire du nouvel inscrit. De plus un dossier "html" est créé dans ce répertoire, il contiendra toutes les pages visitées ainsi que les images téléchargées.

Archivage (Fichier .ZIP)

L'archivage permet de sauvegarder tout le répertoire d'un utilisateur "xxx" (traces, historique, pages vues, documents, etc.) dans un fichier unique comprimé (fichier "xxx.zip") en tenant compte de la hiérarchie du répertoire "xxx". Ce fichier est sauvegardé dans le répertoire des utilisateurs.

Sélectionner un ou plusieurs inscrits. Un bouton de commande "Archiver" et 2 cases à cocher permettent alors de :
- "Conserver les données" : le répertoire de l'utilisateur et toutes ses données sont conservées.
- "Supprimer l'utilisateur" : le répertoire de l'utilisateur est supprimé et le nom de l'utilisateur est aussi supprimé de la liste des inscrits.

L'archivage permet de transporter tout le travail d'un utilisateur sous forme d'un fichier unique qui peut être ensuite copier sur un support de sauvegarde (disquettes, etc.). A cause du grand nombre de fichiers composant les données de l'utilisateur, la copie d'une archive au format zip s'effectue beaucoup plus rapidement.

Si un utilisateur archivé a été supprimé, il est possible de récupérer toutes ses données (voir ci-dessous : "Régénération d'un utilisateur").

Suppression

Sélectionner un ou plusieurs inscrits. Un bouton de commande "Supprimer" et trois cases à cocher permettent alors de :

- Supprimer le (ou les) inscrit(s) sélectionné(s) de la liste en conservant cependant tout son répertoire.
- Supprimer le (ou les) inscrit(s) sélectionné(s) de la liste en supprimant aussi son répertoire.
- Supprimer uniquement les pages visitées au cours des navigations et qui sont sauvegardées sur le disque, ainsi que les dossiers images correspondants. Seuls seront conservés les documents archivés de l'utilisateur, les fichiers "traces" et "historique" sont réinitialisés (comme pour une nouvelle inscription). Cette dernière option est utile pour libérer de la place sur le disque dur. Une heure de navigation avec ARI peut nécessiter, en fonction des pages visitées, de 2 à 3 Mo, voire plus.

Si la suppression concerne un groupe ou un membre d'un groupe, un message demande confirmation de la suppression.

Régénération d'un utilisateur

Elle se fait à partir d'un fichier comprimé .zip qui doit se trouver dans le répertoire de sauvegarde des utilisateurs.
Une fois la case cochée, le bouton de commande "Sélectionner un fichier" permet de sélectionner le fichier .zip à régénérer. Si l'utilisateur est inscrit dans le répertoire de sauvegarde, la régénération remplace le dossier de l'utilisateur par les données du fichier comprimé, sinon elle inscrit l'utilisateur et créé son dossier avec toutes les données du fichier comprimé.


onglet Mises à jour

L'onglet Mises à jour

[ Accueil ] [ Remonter ]

Utilisateurs inscrits

Les noms sont triés par ordre alphabétique croissant. La liste permet de sélectionner un ou plusieurs inscrits. Pour sélectionner plusieurs inscrits séparemment, maintenez la touche CTRL enfoncée puis cliquez sur les éléments à sélectionner. Pour sélectionner un groupe d'inscrits qui se suivent dans la liste, sélectionner le premier et en maintenant enfoncé le bouton de la souris, amener la souris sur le dernier élément à sélectionner.

Régénération d'un historique

Sélectionner un ou plusieurs inscrits.
Une case à cocher et un bouton de commande "Effectuer la création" permettent de recréer un historique (fichier "xxx_Histo.csv") du parcours d'un (ou plusieurs) utilisateur(s) à partir du fichier contenant la trace des événements enregistrés (fichier "xxx.csv") et de son dernier historique.

Mise à jour de la version 4.1 à la version 4.3

Cette mise à jour est nécessaire pour récupérer les données d'un utilisateur de la version 4.1
Sélectionner un ou plusieurs inscrits.
Cocher "Fichiers trace et historique"
Effectuer la mise à jour.


onglet Modèles

L'onglet Modèles

[ Accueil ] [ Remonter ]

Modèles disponibles

La liste des modèles, utilisables lors des prises de notes, qui figurent dans le répertoire "modeles" de l'application est affichée. Sélectionner un des modèles proposés. Si le fichier de description du modèle fait référence à une image donnant un aperçu de la mise en page, cette image est affichée à droite.

Enregistrer le modèle sélectionné

Permet d'enregistrer ou non dans le fichier de configuration le nom du modèle sélectionné. Si la case est cochée, alors le modèle sera aussi utilisé pour les sessions suivantes ; sinon il n'est pas enregistrée et, dans ce cas, il n'est utilisé comme modèle pour la prise de notes que tant qu'on ne quitte pas le logiciel ou que l'utilisateur n'est lui même décidé d'en changer (voir le "visionneur de notes").


onglet Groupes

L'onglet Groupes

[ Accueil ] [ Remonter ]

Un groupe est un ensemble d'utilisateurs inscrits. Leurs historiques, rapports et archives sont réunis pour ne constituer qu'un utilisateur unique.

Lorsqu'on clique sur l'onglet groupes, si des groupes ont été créés, la liste correspondante est affichée et, pour le groupe sélectionné dans cette liste, ARI affiche aussi :

  • entre [] les membres de ce groupe
  • le commentaire qui a été introduit lors de la création du groupe

Supprimer le groupe

Permet de supprimer le groupe sélectionné dans la liste. La suppression peut aussi être effectuée dans l'onglet "Utilisateurs".

Créér un groupe

ARI ouvre une boîte de dialogue et affiche dans la partie centrale de l'onglet deux zones de texte qui contiendront le nom de ce groupe et un commentaire associé.

  • Taper le nom du groupe dans la boîte de dialogue qui est ouverte
  • Taper éventuellement le commentaire associé à ce groupe
  • Sélectionner les inscrits qui font partie de ce groupe
  • Valider l'inscription avec le bouton "Inscrire le groupe" (le groupe est alors affiché dans la liste des groupes céés) ou Annuler cette inscription avec le bouton "Annuler".


La barre de navigation

[ Accueil ] [ Note importante ]

Un utilisateur étant sélectionné, lorsqu'on clique sur le bouton "Naviguer" de la fenêtre principale (voir description ci-dessus), une barre masquable est affichée en haut de l'écran.

Cette barre contient quatre boutons de commande en mode normal "Quitter", "Naviguer", "Historique", "Barre masquable" et un 5ème "Trace" en mode administrateur.

Le bouton "Fermer"

Il permet de retourner à la fenêtre principale.

Le bouton "Naviguer"

Il lance le navigateur Internet Explorer sur la page dont l'adresse est précisée dans le fichier de configuration "ari.ini" (voir ci-dessus) ou, en l'absence de cette précision, sur la page de démarrage par défaut du navigateur. Une fois le navigateur ouvert, le bouton porte le nom "Nouvelle fenêtre". Utiliser ce bouton pour ouvrir simultanément plusieurs fenêtres lors de la navigation.

Voir la Note importante concernant l'ouverture d'une nouvelle fenêtre.

Le bouton "Historique"

Il affiche dans une fenêtre flottante située au premier plan un bouton "M" et l'historique de la session en cours et des sessions précédentes. Ce bouton permet de développer toutes les branches de l'historique qui ont été "marquées" par l'utilisateur (voir ci-dessous).

En mode "administrateur" une boîte combo est aussi affiché à côté du bouton "M". Elle permet d'adapter l'affichage de l'historique : "Sessions" qui est l'affichage du mode utilisateur, "Chrono" qui affiche une liste strictement chronologique et "Arbre" qui affiche les consultations de sites dans l'ordre chronologique.

Dans l'historique, les adresses des pages téléchargées sont affichées en gras.

Pour masquer la fenêtre de l'historique, cliquer à nouveau sur le bouton.

La souris étant positionnée sur une URL, un clic sur le bouton droit de la souris fait apparaître un menu contextuel proposant trois options :

  • "Afficher le document distant" : permet de lancer le navigateur sur l'adresse de la page correspondante.
  • "Marquer/Démarquer" : permet de signaler ce document comme intéressant. L'adresse change de couleur. Démarquer ramène à l'état normal.
  • "Supprimer" : permet de ne plus afficher ce document.

En fait, l'option "Supprimer" ne supprime pas le document téléchargé du disque. Les options "Marquer" et "Supprimer" créent chacune un fichier dans lequel sont notées les références des parties de l'historique qui sont marquées ou supprimées (fichiers "xxx_Histo_M.txt" et "xxx_Histo_S.txt").

Le bouton "Barre masquable"

La barre de navigation peut être masquée pour améliorer l'affichage.
Cliquer sur ce bouton et la barre de navigation disparaît au bout de 1 à 2 secondes.
Pour la faire apparaître, emmener la souris tout en haut de l'écran. Tant que la souris reste sur la barre, celle-ci reste visible. Un clic sur "Barre masquable" permet de revenir à la situation initiale.

Le bouton "Trace"

Uniquement disponible en mode administrateur, il ouvre une fenêtre contenant les traces des différents évènements IE enregistrés au cours des différentes sessions.
Dans cette fenêtre sont affichées : l'événement, l'adresse de la page, la date, l'heure et le n° de la fenêtre dans laquelle la page a été chargée.
Pour masquer la fenêtre, cliquer à nouveau sur le bouton.

La description du code des évènements est décrite dans "Fichier de configuration" (voir [TRACE_MODE]).

Le bouton "Notes"

Permet d'accéder directement à la fenêtre de prise des notes.


Note importante pour la navigation

[ Accueil ] [ Remonter ]

Seules les fenêtres ouvertes par le bouton "Naviguer" ou "Nouvelle fenêtre" de la barre de Navigation et celles qui sont ouvertes avec l'option "Ouvrir dans une nouvelle fenêtre" du menu contextuel de Internet Explorer sont tracées et analysées.

Pour que les traces et que les pages visitées soient enregistrées, il ne faut pas lancer Internet Explorer à partir de la barre des tâches, ou par un double-clic sur son icône, indépendamment de l'application "ARI".
De même, il ne faut pas ouvrir une nouvelle fenêtre du navigateur à l'aide du menu d'Internet Explorer "Fichier > Nouveau > Fenêtre", mais toujours à l'aide du bouton "Naviguer" ou "Nouvelle fenêtre" de la barre de navigation. Pour cela, faire apparaître la barre masquable si elle est masquée puis cliquer sur le bouton "Nouvelle fenêtre".


Prendre des notes

Prise de notes

[ Accueil ]
        [ Barre de commandes ]
        [ Historique ] [ Lecteur de pages ]
        [ Editeur de plan ]
        [ Editeur HTML ]
        [ Visionneur de notes ]

Pour afficher cette fenêtre , cliquer sur le bouton "Prendre des notes" dans la fenêtre principale.

Cette fenêtre permet de créer un document ou plusieurs documents de notes au format HTML à partir :

  • d'extraits de copies locales des pages visitées au cours des différentes sessions
  • de texte libre directement saisi par l'utilisateur

Les éléments composant le document peuvent être organisés dans une structure hiérarchique.

Le résultat de cet assemblage peut alors être visualisé dans un navigateur, en fournissant automatiquement les références des pages HTML à partir desquelles il a été composé.

La fenêtre de prise de notes est composée :

  • d'une barre de commandes (1)
  • d'un historique (2) associé à un lecteur de pages (3)
  • d'un éditeur de plan (4) du document, associé à :
    • un éditeur HTML pour modifier les différentes parties du document
    • un visionneur de notes (5) permettant d'afficher un document ou un sous-document, de modifier sa mise en page, de l'imprimer ou de reprendre la navigation à partir du document ainsi composé.


Barre de commandes

[ Accueil ] [ Remonter ]

Située en haut de la fenêtre, elle contient les boutons suivants :

  • Ferme la fenêtre de Prise de notes, et retourne à la fenêtre principale
  • Affiche uniquement l'historique des sessions ainsi que le lecteur de pages HTML copiées localement
  • Affiche en même temps l'historique des sessions, le lecteur de pages de pages HTML copiées localement, l'éditeur de plan et l'éditeur d'extraits (ou le visionneur de notes), permettant ainsi un affichage simultané de toutes les possibilités du logiciel.
  • Affiche uniquement l'éditeur de plan ainsi que le visionneur de notes ou l'éditeur d'extraits HTML
  • Affiche un panneau d'aide permettant de consulter l'aide du logiciel.


Historique

[ Accueil ] [ Remonter ]

Une ligne en gras correspond à une page dont la copie locale a été réalisée avec succès.

Les deux boutons situés en haut permettent de :

  • développer toutes les branches de l'historique qui ont été "marquées" par l'utilisateur (voir ci-dessous). En mode "administrateur" une boîte combo est aussi affiché à côté du bouton "M". Elle permet d'adapter l'affichage de l'historique : "Sessions" qui est l'affichage du mode utilisateur, "Chrono" qui affiche une liste strictement chronologique et "Arbre" qui affiche les consultations de sites dans l'ordre chronologique.
  • d'afficher la copie suivante lorsqu'elle existe

Pour afficher la page, cliquer avec le bouton gauche de la souris.
La page est alors affichée dans le lecteur de pages, placé à droite de l'affichage de l'historique.

Cliquer avec le bouton droit fait apparaître un menu contextuel permettant :

  • de relancer la navigation avec traçage sous ARI sur la page concernée ("Afficher le document distant")
  • de marquer (ou de démarquer) un document, qui apparaît alors en bleu ainsi que le site
  • de supprimer le document de l'arborescence (la copie locale est tojours conservée sur le disque)

Il est possible :

  • de masquer l'historique en cliquant sur le bouton [image] du lecteur de pages, afin de faciliter la consultation
  • de masquer les notes à l'aide du bouton [image] de la barre de commandes


Lecteur de pages

[ Accueil ] [ Remonter ]

Situé à droite de l'historique, il permet de consulter les pages HTML conservées localement et de sélectionner des fragments. Les liens de navigation des pages sont désactivés dans cet affichage.

Les fragments qui sont extraits des pages visualisées sont toujours créés dans le document actif de l'éditeur de plan.

Création d'un extrait

Pour copier tout ou partie d'une page HTML visualisée afin d'ajouter un extrait aux notes, plusieurs boutons sont disponibles :

  • crée un extrait contenant l'intégralité de la page
  • crée un extrait contenant la portion sélectionnée de la page
  • Ces deux boutons permettent de sélectionner plus facilement des extraits.

    Quand "Sélection rapide" est enfoncé, le fragment situé sous le pointeur de souris dans le visualisateur est délimité visuellement par changement de la couleur de fond. Il suffit alors de cliquer avec le bouton gauche de la souris pour sélectionner le fragment en question.
    Cliquer sur la flèche vers le haut sélectionnera le fragment englobant la sélection courante, et ainsi de suite.

Autre méthode de copie :
Si l'éditeur de plan est affiché, il suffit de placer l'extrait sélectionné dans le plan du document par glisser-déposer (drag & drop).

  • cliquer sur la sélection dans le visualisateur
  • sans lâcher le bouton de la souris, glisser vers un dossier ou un document dans l'éditeur de plan
  • relâcher le bouton. L'extrait est créé comme dernier extrait du dossier de destination, ou après le document de destination.

Autres commandes

  • Permet de sélectionner le document actif dans l'éditeur de plan.
  • Permet de rechercher du texte dans la page courante
  • Masque l'historique, permettant ainsi une visualisation plus aisée de la page HTML.


Editeur de plan de notes

Editeur de plan

[ Accueil ] [ Remonter ]
Cet outil permet d'organiser les notes en plusieurs documents à plusieurs niveaux.

Le rôle des boutons situés en haut est (de gauche à droite) :

  • Création d'un nouveau document ou d'un sous-document dans le document en cours
  • Création d'un extrait vide, modifiable dans l'éditeur
  • Duplication d'un extrait
  • Suppression d'un extrait ou d'un document (mais il faut conserver au moins un document)
  • Remonter vers le haut ou vers le bas l'extrait ou le document sélectionné en restant au même niveau de l'arborescence.
  • Afficher ou masquer la zone de commandes située sous le plan

Pour déplacer des dossiers/documents n'importe où dans l'arborescence , utiliser le "glisser-déposer" (drag & drop) à la souris :

  • Cliquer sur l'icône correspondant au document ou à l'extrait à déplacer
  • Sans lâcher le bouton de la souris, glisser vers le document de destination
  • Relâcher le bouton. Le document ou extrait source est déplacé à la fin du document de destination. Le déplacer ensuite avec les flèches haut et bas.

La sélection d'un élément du plan permet :

  • dans le cas d'un document, son affichage avec le visionneur de notes et son impression
  • dans le cas d'un extrait , sa modification avec l'éditeur HTML

Il est possible :

  • de masquer l'éditeur de plans en cliquant sur le bouton [image] de l'éditeur HTML, pendant l'édition d'un extrait
  • d'agrandir la zone de travail en masquant l'affichage de l'historique à l'aide de la barre de commandes

Zone de commandes associée au plan

Située sous l'arborescence des dossiers/documents, elle permet :

  • quand un dossier est sélectionné :

    de copier ("Archiver") tous les fichiers associés à un document, dans le sous-répertoire "rapports" de l'utilisateur. Il est créé un répertoire par document, portant le même nom que le document.
    La liste présente toutes les archives de l'utilisateur courant, avec possibilité de suppression définitive.

  • quand un extrait est sélectionné :

    • d'afficher l'extrait d'origine
    • de revenir à l'extrait d'origine quand l'extrait a été modifié
    • d'afficher dans le lecteur de page la page dans laquelle on a extrait un fragment.
    • de rédiger un commentaire, qui apparaîtra dans le bandeau supérieur associé au fragment lui-même


Editeur de fragments HTML

Editeur d'extraits HTML

[ Accueil ] [ Remonter ]

Cet éditeur permet de modifier un extrait ou de rédiger un nouveau extrait.

Il dispose d'une barre de menus

permettant les opérations suivantes :

  • Edition : Copier, Coller, ...
  • Voir : permet l'affichage des bordures de tableau et des détails de l'extrait HTML
  • Format : définit le style du paragraphe en cours
  • Table : gestion des tableaux HTML
  • 2D : positionnement absolu ou en ligne des éléments graphiques de la page

Le choix de la police courante se fait à l'aide d'un barre d'outil spéciale :

tandis que la mise en forme des caractères et des paragraphes se fait à l'aide de la barre d'outils classique :

  • Gras, Italique, Souligné, Couleur du texte sélectionné
  • liste numérotée
  • liste à puces
  • retraits des paragraphes
  • alignement des paragraphes (gauche, centré, droite)

La sauvegarde des modifications est automatique dès que l'on sélectionne un autre élément, extrait ou document.


Visionneur de notes

[ Accueil ] [ Remonter ]

Situé à droite du plan, il permet d'afficher un document ou un sous-document. Dans cet affichage, les liens de navigation sont désactivés.

Les commandes disponibles sont les suivantes :

permet de relancer directement la navigation sur le document en cours.

permet d'imprimer le document en cours.
La sélection d'un sous-document dans le plan permet de n'imprimer que cette partie du document complet.

permet de modifier la mise en page du document en changeant de modèle.

Lorsqu'on clique sur ce bouton une boîte de dialogue analogue à celle de l'onglet "Modèles" (dans la gestion) est affiché.

Sélectionner un des modèles proposés puis :

  • cliquer sur "Valider" pour modifier la mise en page du document,
  • cliquer sur "Annuler" pour conserver la mise en page actuelle.

Note : La sélection du modèle par l'utilisateur n'est pas enregistrée comme modèle par défaut dans le fichier de configuration.

permet de savoir si le document visualisé est le document temporaire en cours d'élaboration ou un document archivé.


Exploitation des traces

[ Accueil ]

Les fichiers sont sauvegardés au format CSV directement exploitable avec Excel ou un éditeur de texte.

Sa structure est la suivante :

- La première ligne contient le numéro de version du logiciel.
- La deuxième ligne contient le nom de l'utilisateur.
- Les lignes suivantes correspondent aux traces sauvegardées.

Chaque ligne comprend de 6 à 8 cellules contenant respectivement :

1- la date
2- l'heure
3- le code de l'événement
4- l'événement
5- la fenêtre en cours
6- le cadre d'où vient la requête ou le titre de la fenêtre, etc.
7- le cadre dans lequel la requête est lancée
8- l'URL du départ de navigation (adresse du serveur ou de la page)

Si on ne s'intéresse qu'aux pages visitées, seules les colonnes 1, 2, 4 et 8 des événements Dnav sont utiles.

Sous Excel, effectuer un filtre automatique (menu "Données > Filtre > Filtre automatique") sur la colonne "événement" (4 ème colonne).
Puis cliquer sur la flèche située dans la colonne qui contient les données à comparer.
Il suffit alors de sélectionner, par exemple, les débuts de navigation (DNav) pour n'afficher que les lignes correspondant aux sites (ou pages) qui ont été visités.


Contacts et informations complémentaires

Contacts

[ Accueil ]

ARI a été conçu et réalisé par :

  • François-Marie Blondel
  • Jean-Claude Le Touzé
  • Martial Tarizzo
  • avec la contribution de Alain Beaufils.

Ce travail est effectué dans le cadre d'un projet à l'Institut national de recherche pédagogique. Pour tous renseignements complémentaires :

INRP
Département Technologies nouvelles et éducation
91, rue Gabriel Péri, 92120 Montrouge
Fax. 01 46 12 87 01
Mél : Francois-Marie.Blondel@inrp.fr

Informations complémentaires sur le logiciel ARI

http://www.inrp.fr/Tecne/Savoirplus/Rech40123/ari/accueil.html

Informations concernant ce travail

  • sur la recherche d'informations par les collégiens et les lycéens :
    http://www.inrp.fr/Tecne/Savoirplus/Rech40123/riicl/accueil.html
  • sur les Activités documentaires sur Internet en physique-chimie :
    Site ADIPC pages références http://www.inrp.fr/Tecne/adipc/refs/refs-index.htm
    Site ADIPC pages aides http://www.inrp.fr/Tecne/adipc/aides/aides-index.htm


Pour modifier les couleurs

  1. Dans Internet Explorer 4.0, cliquez dans le menu Affichage sur Options Internet.
  2. Sous l'onglet Général, cliquez sur Couleurs.
  3. Dans la boîte de dialogue Couleurs, sélectionnez les options souhaitées, puis cliquez sur OK.
  4. Sous l'onglet Général, cliquez sur Accessibilité.
  5. Sous Mise en forme, activez les cases à cocher des options souhaitées, puis cliquez sur OK.
  6. Pour appliquer les nouveaux paramètres de couleurs, cliquez dans la boîte de dialogue Options Internet sur OK.
Remarque
  • Cette procédure ne modifie que la couleur du droit de la fenêtre d'aide.


Pour modifier les polices

  1. Dans Internet Explorer 4.0, cliquez dans le menu Affichage sur Options Internet.
  2. Sous l'onglet Général, cliquez sur Polices.
  3. Dans la boîte de dialogue Polices, sélectionnez les options souhaitées, puis cliquez sur OK.
  4. Sous l'onglet Général, cliquez sur Accessibilité.
  5. Sous Mise en forme, activez les cases à cocher des options souhaitées, puis cliquez sur OK.
  6. Pour appliquer les nouveaux paramètres des polices, cliquez dans la boîte de dialogue Options Internet sur OK.
Remarque
  • Cette procédure ne modifie que la police du droit de la fenêtre d'aide.


Pour afficher et masquer le sommaire de l'aide

  • Dans la barre d'outils de l'aide, cliquez sur le bouton Masquer Masquer pour masquer la table des matières, l'index ou la liste des résultats de la recherche.
  • Dans la barre d'outils de l'aide, cliquez sur le bouton Afficher Afficher pour afficher la table des matières, l'index ou la liste des résultats de la recherche.


Pour copier une rubrique d'aide

  1. Dans le droit de la fenêtre d'aide, cliquez avec le bouton droit sur la rubrique que vous souhaitez copier, puis cliquez sur Sélectionner tout.
  2. Dans la rubrique, cliquez de nouveau avec le bouton droit, puis cliquez sur Copier.

    La rubrique est ainsi copiée dans le Presse-papiers.

  3. Ouvrez le document dans lequel vous souhaitez copier la rubrique.
  4. Cliquez dans le document à l'endroit où vous souhaitez que ces informations apparaissent.
  5. Dans le menu Edition, cliquez sur Coller.
Remarque
  • Si vous ne souhaitez copier qu'une partie d'une rubrique, sélectionnez cette partie, cliquez dessus avec le bouton droit, puis cliquez sur Copier.


Pour rechercher une rubrique d'aide

  1. Dans l'aide, cliquez sur un des onglets suivants :
    • Pour parcourir les rubriques par catégorie, cliquez sur l'onglet Sommaire.
    • Pour afficher la liste des entrées d'index, cliquez sur l'onglet Index, puis tapez un mot ou faites défiler la liste.
    • Pour rechercher des mots ou des expressions susceptibles de figurer dans une rubrique d'aide, cliquez sur l'onglet Rechercher.
  2. Dans le gauche de la fenêtre d'aide, cliquez sur la rubrique, l'entrée d'index ou l'expression correspondant à la rubrique que vous souhaitez afficher dans le cadre droit.
Remarque
  • Cliquez sur le bouton Aide Web Aide Web de la barre d'outils de l'aide pour accéder au support technique, obtenir les réponses aux questions les plus courantes et profiter des tout derniers conseils relatifs à l'utilisation de Windows.


Pour obtenir de l'aide dans une boîte de dialogue

Dans la barre de titre de la boîte de dialogue, cliquez sur le bouton point d'interrogation ?, puis sur un élément de la boîte de dialogue.

Remarques

  • Vous pouvez imprimer ou copier des informations affichées dans une fenêtre contextuelle en cliquant dans celle-ci avec le bouton droit, puis en cliquant sur Imprimer la rubrique ou Copier.
  • Pour fermer la fenêtre contextuelle, cliquez dans celle-ci.
  • Si la boîte de dialogue ne comporte pas de bouton point d'interrogation ?, cliquez sur ? (Aide), ou appuyez sur F1.
  • Pour afficher l'aide relative à un élément, cliquez dessus avec le bouton droit, puis cliquez sur Qu'est-ce que c'est ?.


Pour imprimer une rubrique d'aide

  1. Dans le droit de la fenêtre d'aide, cliquez sur la rubrique que vous souhaitez imprimer.
  2. Dans la barre d'outils de l'aide, cliquez sur Options, puis sur Imprimer.
Remarques
  • Si vous imprimez à partir de l'onglet Sommaire, il vous sera proposé d'imprimer la rubrique en cours, toutes les rubriques qui s'affichent sous le livre sélectionné ou toutes les rubriques du sommaire.
  • Pour imprimer une rubrique contextuelle, cliquez avec le bouton droit dans la fenêtre contextuelle, puis cliquez sur Imprimer la rubrique.


Pour accéder à un complément d'aide

Dans une rubrique d'aide, vous pouvez cliquer sur les mots soulignés et accéder ainsi à des informations complémentaires.

  • Pour afficher la définition d'un terme souligné, cliquez simplement dessus. Faites un essai et vous verrez s'afficher la définition de puis cliquez de nouveau pour la faire disparaître.
  • Pour ouvrir une application, une page sur Internet ou une autre rubrique, cliquez sur les mots « cliquez ici » qui apparaissent soulignés et en couleur. Essayez cliquez ici pour aller à une autre rubrique.
  • Pour sélectionner d'autres rubriques contenant des informations connexes, essayez de cliquer sur les mots soulignés, « Rubriques connexes », qui figurent à la fin de certaines rubriques, puis cliquez sur le titre de la rubrique qui vous intéresse.


Pour vous déplacer dans les rubriques d'aide que vous avez affichées

  • Dans la barre d'outils de l'aide, cliquez sur En arrière En arrière pour afficher la dernière rubrique d'aide que vous avez visualisée.
  • Dans la barre d'outils de l'aide, cliquez sur En avant En avant pour afficher la rubrique d'aide suivante d'une série de rubriques que vous avez déjà affichée.


Pour modifier la taille de la fenêtre
  • Pour augmenter ou réduire la largeur du gauche ou droit, pointez sur la ligne de séparation entre les deux cadres. Dès que le pointeur prend la forme d'une flèche à deux pointes, maintenez le bouton gauche de la souris enfoncé et faites glisser la ligne de séparation vers la droite ou vers la gauche.
  • Pour que la réduction ou l'agrandissement soit appliqué de manière proportionnelle à la totalité de la fenêtre d'aide, pointez sur un de ses coins. Dès que le pointeur prend la forme d'une flèche à deux pointes, maintenez le bouton gauche de la souris enfoncé et faites glisser le coin.
  • Pour modifier la hauteur ou la largeur de la totalité de la fenêtre d'aide, pointez sur son bord supérieur, inférieur, gauche ou droit. Dès que le pointeur prend la forme d'une flèche à deux pointes, maintenez le bouton gauche de la souris enfoncé et faites glisser le bord choisi.


Aide HTM et CHM - FMB - 14:28 28/11/2001

Reste à faire

Revoir les styles ou l'affectation du style Entete 2 et 3 dans les pages html ?

Historique

image avec copies ? image avec Liste et arbre pour l'administrateur ?

Getion des utilisateurs
renommer Changer en Modifier !

Prise de notes

faire les images de chaque bouton de la zone de commande de l'éditeur de plan
et les détailler dans le texte de l'aide

image "Notes : document temporaire" dans visionneur de notes au lieu de "Rapport : document temporaire"

corriger le fichier prise de notes.htm (balises <nobr> inutiles ????)

Gestion des utilisateurs

image de la fenetre


Fabrication de l'aide - FMB - 16:15 15/02/2002
---------------------

Structuration de l'aide
-----------------------
L'idée est de faire une aide générale autonome qui puisse être lancée indépendamment de ARI mais dont une partie peut être directement liée à ARI et appelée durant son exécution.

fonctionnalités de référence
visites guidées
installation adapations et versions
démonstrations d'utilisation
conseils pour la recherche d'informations

On peut soit créer des sous ensembles html indépendants reliés par une tdm
ou faire des blocs compilés reliés par un chm qui ne contient que la tdm principale

Processus de fabrication avec FAR et HTML Help Worshop
------------------------------------------------------
1 Créer le contenu des documents
Avec Dreamweaver
Faire un ou plusieurs modèles de documents (attention, appliquer un modèle oblige à redonner  un titre à la page)
Les titres de pages doivent être choisis avec soin car ils deviennent les entrées de l'index
Ecrire directement les titres dans le code pour ne pas avoir de codage des caractères accentués qui apparaisent ensuite dans la tdm

2 Organiser les répertoires dans la structure de la tdm souhaitée
en donnant exactement le nom de l'entrée que l'on souhaite dans la tdm
on peut mettre des _ à la place des espaces si ensuite on coche l'option correspondante dans les préférences de FAR

3 Créer la tdm et l'index et compiler le tout avec FAR
La tdm reproduit  la structure des répertoires
l'index est construit à partir des titres des pages
l'index créé n'a qu'un seul niveau
On peut signaler dans FAR les documents que l'on ne veut pas utiliser pour créer l'aide

4 Remanier au besoin l'index et la tdm
Avec l'éditeur de FAR, on peut déplacer les entrées de la tdm et les renommer
on peut aussi renommer les entrées de l'index ou en ajouter

5 Vérifier les liens avec HH Utilities
onglet Check Links
La vérification trouve des liens erronés qd le nom du répertoire contient un caractère avec accent (exemple "désinstallation")

Variante
--------
Avec FAR, on peut aussi fabriquer une aide html en ajoutant uniquement une tdm et un index en html.
Vérifier que le résultat fonctionne aussi sous Netscape.

Commentaires
---------------------
On a intérêt à travailler sur des fichiers situés toujours au même endroit, à cause de la définition des sites avec Dreamweaver et de la mémorisation des derniers fichiers utilisés par FAR (hhp, hhc, hhk, etc.)

Renommer à la  main dans le code HTML les titres des pages qui sinon restent codés avec des &eacute; dans l'index et la tdm.

Liens avec les entrées dans l'aide incluses dans l'application
---------------------------------------------------------------------------------------
Introduire les deux fichiers qui contiennent la correspondance (map) et les alias.
Le fichier map fait la correspondance entre des identificateurs texte et leur équivalent numérique.
Le fichier alias fait la correspondance entre les identificateurs texte et les fichiers html.
Avec HTML Help Workshop, sous l'onglet Project, activer le bouton HTML API Information et inclure les fichiers map et alias.

Questions
---------
Comment déclarer automatiquement les correspondances dans le fichier alias.h ?

Vérifier l'usage de / et \ dans le fichier alias.h !

Aide ARI - pourquoi s'affiche t elle toujours dans une fenetre à part quand on tape F1 et pourquoi y a t il une erreur , l'aide ne s'affiche pas dans la fenetre associée à la prise de notes quand on clique sur le bouton aide ?
Réponse :
Pour afficher dans le browser associé à la prise de notes, il faut respecter dans le code :
WebBrowserHelp.Navigate "ms-its:" & App.Path & "\aide\ari.chm::/Utilisation/Rapports/création_de_rapport.htm"
solution en test le 27/11/2001
ajout de la page création_de_rapport.htm qui est une copie de prise_de_notes.htm avec adaptation des liens, dans le rep /Utilisation/Rapports/
Il faut encore refaire la map section et les alias !!!!!
On pourrait aussi pour simplifier afficher l'aide dans une fenetre indépendante comme avec F1.

Pourquoi récupère t on des codes &eacute; dans le sommaire de l'aide et dans l'index ?
A cause des titres des pages modifiés dans Dreamweaver
Solution : taper les titres directement dans le code html des pages.